Power Steering, Hill Assist, Traction Control, ABS & Speed Odometer Failure - Page 5
Page 5 of 5 FirstFirst ... 345
Results 41 to 50 of 50
Like Tree12Likes
Discuss Power Steering, Hill Assist, Traction Control, ABS & Speed Odometer Failure at the Focus ST Repair Shop / Service within the Ford ST Nation; Originally Posted by jasonpugh Replaced ...
  1. #41
    The Site Founder Chad's Avatar
    Join Date
    Nov 2011
    Location
    Midland, Michigan
    Posts
    3,422
    Chats
    4349
    Occupation
    Information Technology
    My Ride
    Tangerine Scream Focus ST3
    Name
    Chad
    Quote Originally Posted by jasonpugh View Post
    Replaced both front sensors and it still didn't fix the issue. Should I replace the rear sensors even though they weren't touched? Any ideas? I assume the sensors have to be the issue. What else could cause similar symptoms? It's driving me nuts.....no pun intended.
    Jason

    Did you take it to the dealer? Its not just the sensor, its the pigtail as well... Let them spend the time to fix it. Its under warranty.

    Quote Originally Posted by Bigrob9602 View Post
    Just took my ST to the dealer today for the exact symptoms you described. They wcouldnt figure it out and got me a rental. Now I can call them up Monday and tell them how to fix my car. Chad you sir are the man! So glad I looked in here!
    Glad to help.
    Forum Policies: AUP | Privacy Policy

    Chad's Current Modifications
    Green Filter
    CP-E™ Stage II Rear Motor Mount
    CP-E™ 3" DownPipe
    CP-E™ Austenite™ 3" Exhaust with HEXtip™ Exhaust Tip
    CP-E™ αIntake™ Intake System
    Wilwood 6 Piston 13" BBK
    Clear Lens Retrofit w/ Osram Xenarc 66240 D2S CBI
    Rostra LED Projector Fog

    Coming soon:
    Ford Racing Intake, Plugs & Procal
    Breedt Shift Arm

  2. #42
    ST Nation Corporal
    Join Date
    Oct 2012
    Posts
    64
    Chats
    4
    I have an appointment tomorrow at 2pm. I want my baby back to normal.

  3. #43
    ST Nation Corporal
    Join Date
    Oct 2012
    Posts
    64
    Chats
    4
    So, according to Ford, it's the wheel bearing for me, not the sensor. Apparently the tone sensor is built into our wheel bearings and isn't the traditional type tone ring. It will be replaced Friday. I'll report back if it fixed the issue.

  4. Remove Advertisements
    FordSTNation.com
    Advertisements
     

  5. #44
    ST Nation Corporal
    Join Date
    Oct 2012
    Posts
    64
    Chats
    4
    Well guys, I'm happy to report she is back to normal. It was the tone sensor which is built into our wheel bearings.
    Chad likes this.

  6. #45
    ST Nation Officer Enlist jtswank's Avatar
    Join Date
    Nov 2012
    Location
    Virginia
    Posts
    1,693
    Chats
    129
    Occupation
    MD
    My Ride
    2010 F-150 crew cab, 2013 Focus TB ST3
    Name
    JT
    Glad that you are fixed. So is the same problem or different than what chad had?
    TB ST3 Build Date = 1/2/2013

  7. #46
    ST Nation Corporal
    Join Date
    Oct 2012
    Posts
    64
    Chats
    4
    It was different. I believe Chad's issue was the speed sensor, while mine was the tone ring that works with the speed sensor.

  8. #47
    ST Nation Officer Enlist jtswank's Avatar
    Join Date
    Nov 2012
    Location
    Virginia
    Posts
    1,693
    Chats
    129
    Occupation
    MD
    My Ride
    2010 F-150 crew cab, 2013 Focus TB ST3
    Name
    JT
    Wow what are the odds of that ... Interesting.
    TB ST3 Build Date = 1/2/2013

  9. #48
    ST Nation Enlist
    Join Date
    Apr 2016
    Posts
    1
    Chats
    0
    having a similar problem with mine... while cruising on the highway on multiple occasions my Brake light, ABS light and Stability light have all flashed and then gone off. any help if appreciated

  10. #49
    ST Nation Enlist Adam925's Avatar
    Join Date
    Mar 2017
    Posts
    2
    Chats
    0
    So here's my case... im in a 2016 Focus ST still under warranty... less than 10,000 miles on it and all of the above described details happen the other night in this order... 1st i get a message pops up saying "Hill Start Assist Failure" , then ABS light followed by Traction Control light with an Exclamation point! This all happens while i am ordering some drive thru from MCdonalds then as i drive out the drive through i notice steering is not normal... hard 2 turn and i end up Curbing my back right Tire and then Every light possible on my dash lights up... and as i start to drive i notice both my Digital Speedometer and Analong are displaying "0" mph... when im clearly doing at least 45 to 50... Any how... i end up dropping it off 1st thing next day with the dealer... they had it for 4 days and when i went to pick it up... they tell me its fixed and it was the speed sensor or sensors..... so i hop in start her up and off i go only to get down the block and it all happens again... WTF IM HEATED!!! took it right back and blew my top in the process.... so im out a car... its still in the shop.... and its only got 9,480 miles on it.... WHAT SHOULD I DO???FORD EDITED.jpghttps://youtu.be/VMqkQ17NDIw

  11. #50
    ST Nation Enlist gtx2867r_ST's Avatar
    Join Date
    Jan 2017
    Posts
    4
    Chats
    0
    Mine did something similar today... Started off saying Steering assist was unavailable.. no speedo... tach kept falling off..Idling like crap... And something on the engine was chirping. Limp it it home... Pull in the driveway then I get the hill assist unavailable... Had to push the ignition a few times to shut it off. It started RIGHT back up... Tried to access my Cobb AP... And it wasn't reading the ecu... Kept telling me it was trying to connect. Unplugged the AP.... Shut my car off​ again.... Restarted and everything is fine 😭😭

    Sent from my SAMSUNG-SM-G891A using Tapatalk

Page 5 of 5 FirstFirst ... 345

Similar Threads

  1. Hill Launch Assist (HLA) or Equivalent in US Focus ST?
    By Brandon in forum Focus ST General Discussion
    Replies: 65
    Last Post: 03-07-2013, 12:11 PM
  2. A question about Traction Control
    By trip9 in forum Focus ST General Discussion
    Replies: 14
    Last Post: 12-01-2012, 03:16 AM
  3. Hill Start Assist? No thanks
    By RazorbackMustang in forum Focus ST General Discussion
    Replies: 25
    Last Post: 10-22-2012, 08:56 PM
  4. Hill-Assist
    By higgrit in forum Focus ST General Discussion
    Replies: 14
    Last Post: 10-22-2012, 11:25 AM
  5. Traction control button?
    By Josh157 in forum Focus ST Performance
    Replies: 11
    Last Post: 05-14-2012, 09:49 PM

Search tags for this page

2012 ford focus steering sensor esp light
,

2013 ford fiesta hillstart assist stability control lights both on

,

2013 ford focus speedometer is not working

,

2014 ford focus assisted hill error

,
2014 ford focus traction control turn off
,

abs light stays on and in service assisted steering

,
cause of ford escape 2013 sel abs sensor failure
,

focus st abs problem

,

ford focus traction control problems

,

i took the battery off a ford focus 2010 and put it back now the traction turns on

,
what causes the abs light traction light to come on abd the speedometer stops working 2014 ford focus
,

where are stability control sensors located on a 2014 ford focus

Click on a term to search our site for related topics.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •